Convert a MAC Address with Hyphen to Colons
If you have a MAC delimited with hyphens:
xx-xx-xx-xx-xx-xx You can convert it to use colons using sed:
echo xx-xx-xx-xx-xx-xx | sed ’s/-/:/g' Which will output as:
xx:xx:xx:xx:xx:xx Anything can be replaced:
echo xx-xx-xx-xx-xx-xx | sed ’s/-/%/g' Would output:
xx%xx%xx%xx%xx%xx
Connecting to a Virtual Machine’s Serial Console with OS X and VMware Fusion
Fusion does have many of the features of VMware workstation but they are not all available in the GUI. An example of this is when you need a VM which only has a serial console. Make sure you have added the virtual serial hardware from the ‘other’ section in the settings. Next you need to edit the vmx file to add the correct settings:
serial0.fileType = "pipe" serial0.fileName = "/tmp/serial1" Depending on how many serial devices you have the serial0 may change to serial1 etc.
Create an virtual network interface in an ESX windows guest using VGT (Virtual Guest Tagging)
Get the intel drivers from e1000 NIC (32bit) and install them in your vm. Once installed make sure you configure the network card properties with the correct VLAN tag. Then make sure that you assign the VLAN tag 4095 to the virtual machine’s portgroup.
Creating an ISO image from a CD in OS X
You need to find the device path of your CD drive.:
drutil status Look through the status info for the CD dvice path. It will look like /dev/disk3 or /dev/disk1 depending on your hardware. You then need to unmount the disk:
diskutil unmountDisk /dev/disk3 Now you can use use dd to make an image:
dd if=/dev/disk3s0 of=file_name.iso To mount the image you created:
hdiutil mount file_name.iso
Changing the postfix banner
Make sure that when you send mail from web hosts you have a reverse lookup name that matches your postfix banner. Otherwise you can sometimes get marked as spam by some providers. Use the following to set the postfix name:
postconf -e myhostname=servername Where ‘servername’ is the name of your PTR record. Remember to restart postfix once you have made this change. You can check this with netcat or telnet:
Vyatta interfaces change when converted/migrated in a virtual environment
The virtual appliance you can download already has the correct udev rules which usually cause this situation (see here). There is a file in vyatta which has a record of the specific interface information. When you migrate the machine, this record causes the machine to think the adapters have changed. Edit the following file:
nano /opt/vyatta/etc/config/config.boot You can either remove the interfaces section or edit the interfaces to suit i.e. change the MAC addresses etc.
Improve the viewing of pdfs with your gpu
Go to file > preferences then under general, the check the ‘Use 2D GPU acceleration’:
When you can’t add window server roles as it does not like your original disk
Once you have run a service pack on a server and you try to add a server role, often it will not accept your original source disk. In this case you need to extract the service pack files. For example in the case of Windows 2003 Server SP2, use the command prompt with /x switch to extract the files:
WindowsServer2003-KB914961-SP2-x86-ENU.exe \x:c:\path-to-folder Once it has extracted the files try to add the server role, this time hopefully with success.
Setting up framebuffer in Ubuntu guest under vmware
Log into the linux guest and make sure you have hwlist installed. If you haven’t you can install it with:
sudo aptitude install hwinfo Once that is installed run the following:
sudo hwinfo –framebuffer This returns all the compatible modes:
02: None 00.0: 11001 VESA Framebuffer [Created at bios.450] Unique ID: rdCR.O3PgoQaqFo1 Hardware Class: framebuffer Model: "VMware virtual machine" Vendor: "VMware, Inc" Device: "VMware virtual machine" SubVendor: "V M ware, Inc.